接着讨论个USG的问题,如何设置WAN的IP地址

还是在折腾新光猫。想要跑满千兆,目前800多。
想请教一下USG Pro4 的WAN口如何绑定一个和光猫同网段的静态IP。
config.gateway.jason要如何写?
找个一个专门配置USG 多IP的工具,不熟悉不敢直接替换。https://codepen.io/codycode/full/aVWZvd/
我光猫IP:192.168.100.1
路由LAN口,192.168.1.1
路由WAN1口,pppoe0,想指定WAN1口一个静态IP为192.168.100.2.
这样一是可以解决内网访问光猫问题。二是解决光猫不自动DHCP无法识别到路由问题。

工具生成的json。1、json是不是有问题,2、这段我插到现有json的哪里?

{
“interfaces”: {
“ethernet”: {
“pppoe0”: {
“address”: [
“192.168.100.2/24”
]
}
}
},
“service”: {
“nat”: {
“rule”: {
“1000”: {
“description”: “DNAT for sdn”,
“destination”: {
“address”: “192.168.100.2”,
“port”: “1010”
},
“inbound-interface”: “pppoe0”,
“inside-address”: {
“address”: “192.168.1.1”,
“port”: “1010”
},
“protocol”: “tcp_udp”,
“type”: “destination”
},
“1500”: {
“description”: “Hairpin for sdn”,
“destination”: {
“address”: “192.168.100.2”,
“port”: “1010”
},
“inbound-interface”: “eth0”,
“inside-address”: {
“address”: “192.168.1.1”,
“port”: “1010”
},
“protocol”: “tcp_udp”,
“type”: “destination”
},
“5000”: {
“description”: “SNAT for sdn”,
“outbound-interface”: “pppoe0”,
“outside-address”: {
“address”: “192.168.100.2”
},
“protocol”: “tcp_udp”,
“source”: {
“address”: “192.168.1.1”
},
“type”: “source”
}
}
}
},
“firewall”: {
“name”: {
“WAN_IN”: {
“rule”: {
“2000”: {
“action”: “accept”,
“description”: “Firewall for sdn”,
“destination”: {
“address”: “192.168.1.1”,
“port”: “1010”
},
“protocol”: “tcp_udp”,
“log”: “enable”
},
“2010”: {
“action”: “accept”,
“description”: “Hairpin FW for sdn”,
“destination”: {
“address”: “192.168.1.1”,
“port”: “1010”
},
“protocol”: “tcp_udp”,
“source”: {
“address”: “192.168.100.2”
},
“log”: “enable”
}
}
}
}
},
“port-forward”: {
“hairpin-nat”: “enable”,
“lan-interface”: [
“eth0”
],
“wan-interface”: “pppoe0”,
“rule”: {
“2000”: {
“description”: “Hairpin Portfoward for sdn”,
“forward-to”: {
“address”: “192.168.1.1”,
“port”: “1010”
},
“protocol”: “tcp_udp”,
“original-port”: “1010”
}
}
}
}

如果是为了桥接之后访问光猫,我是这么做的:
我的光猫LAN是192.168.0.1,eth0接光猫,ip设为192.168.0.2/24。代码保存为config.gateway.json 放到站点目录下面。

{
“interfaces”: {
“ethernet”: {
“eth0”: {
“address”: [
“192.168.0.2/24”
]
}
}
},
“service”: {
“nat”: {
“rule”: {
“5011”: {
“description”: “masquerade for LAN”,
“log”: “disable”,
“outbound-interface”: “eth0”,
“protocol”: “all”,
“type”: “masquerade”
}
}
}
}
}

我已经有json了。要插入到哪部分吗

原来的json先备份。我是这么做的。把上面那段代码的第一个大括号{ 和最后一个大括号}去掉,剩下部分插入到原json的最后一个大括号}号前面。注意的是原json倒数第二个}后面要加一个英文逗号 , 字符。即每节都要以逗号分隔。然后可以找一个json校验工具校验一下。没问题就上传。
最后强制同步usg。

还是不折腾JSON了。
把DPI关掉。能跑850左右,虽然不稳定。
等USG啥时候支持web设置WAN口IP再说。这个功能已经提了好几年了,还没实现。

下周我来提吧,正好有个讨论的机会

哈哈。我看国外官方论坛有一个帖子专门提议这个的,说了好几年了。还没有时间表。