请问erx 进入CLI输入账户密码后出现这个是怎么回事?ssh已经允许了。

这个没遇到过呢…如果是linux客户端,或者win 10可以
ssh -v user@ip
看看调试信息,其他操作系统,不太确定了

icrosoft Windows [版本 10.0.17763.914]
© 2018 Microsoft Corporation。保留所有权利。

C:\Users\Administrator>ssh -v znsd@192.168.1.1
OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.5
debug1: Connecting to 192.168.1.1 [192.168.1.1] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_ed25519-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_xmss type -1
debug1: key_load_public: No such file or directory
debug1: identity file C:\Users\Administrator/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_for_Windows_7.7
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6.1p1 Debian-4~bpo70+1
debug1: match: OpenSSH_6.6.1p1 Debian-4~bpo70+1 pat OpenSSH_6.6.1* compat 0x04000000
debug1: Authenticating to 192.168.1.1:22 as ‘znsd’
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:oi/1y36s1P8VYvHYfhnuNrWhoGk3Kb0hR5DDB4/YM3s
debug1: Host ‘192.168.1.1’ is known and matches the ECDSA host key.
debug1: Found key in C:\Users\Administrator/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: pubkey_prepare: ssh_get_authentication_socket: No such file or directory
debug1: SSH2_MSG_SERVICE_ACCEPT received
Welcome to EdgeOS

By logging in, accessing, or using the Ubiquiti product, you
acknowledge that you have read and understood the Ubiquiti
License Agreement (available in the Web UI at, by default,
http://192.168.1.1) and agree to be bound by its terms.

debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: C:\Users\Administrator/.ssh/id_rsa
debug1: Trying private key: C:\Users\Administrator/.ssh/id_dsa
debug1: Trying private key: C:\Users\Administrator/.ssh/id_ecdsa
debug1: Trying private key: C:\Users\Administrator/.ssh/id_ed25519
debug1: Trying private key: C:\Users\Administrator/.ssh/id_xmss
debug1: Next authentication method: password
debug1: read_passphrase: can’t open /dev/tty: No such file or directory
znsd@192.168.1.1’s password:
debug1: Authentication succeeded (password).
Authenticated to 192.168.1.1 ([192.168.1.1]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: network
debug1: console supports the ansi parsing
Linux ubnt 3.10.107-UBNT #1 SMP Sun Jul 14 11:38:40 UTC 2019 mips
Welcome to EdgeOS
Last login: Tue Aug 17 14:02:22 2021
Linux ubnt 3.10.107-UBNT #1 SMP Sun Jul 14 11:38:40 UTC 2019 mips
Welcome to EdgeOS
Last login: Tue Aug 17 14:02:22 2021
debug1: client_input_channel_req: channel 0 rtype exit-signal reply 0
debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to 192.168.1.1 closed.
Transferred: sent 1888, received 2396 bytes, in 0.1 seconds
Bytes per second: sent 23454.6, received 29765.4
debug1: Exit status -1

已经登陆成功了,那估计路由器里什么配错了。你的用户是不是没配置成admin,用的operator?我试了,operator就是这样的现象。

另外,我才发现,你用的是网页右上角这个吧? 这个功能,我看了erx 2.x的实现,其实是从网页telnet到本机的,并不是走的ssh
image

非admin权限用户,只能网页;美国论坛有人提的这个需求

1赞

我应该是admin啊,回头我恢复出厂看看。

那也许是bug,这个就不好说了,要看你的配置啥的。