新手请教ER-X的外网和内网传输速度慢的问题

前言:家里装修、安装宽带是埋了超5类网线,安装的是100M网口的光猫。何奈装修时欠缺考虑,只把光纤拉到门口的小弱电箱,然后再埋了网线到厅和房间。本来光猫自带WIFI,但放在门口弱电箱信号只能覆盖到大厅,房间根本没信号。宽带师傅也说了光纤应该拉大厅,在大厅装光猫再网线分到各个房间的。再改造线路已不可能了,只能关掉光猫自带WIFI,在大厅和房间加装无线路由以实现无线覆盖。

最近在客厅装了台HTPC,想实现家庭影音分享。由于本人的网络水平只是业余级别,到这时才只知道局域网传输100M和1G速度区别。在100M局域网下,共享1080P的影片都会卡,别说我刚下载的30多G的4K血战钢锯岭、50G的4K60帧的比利林恩的中场战事,在100M网口,最多11MB\S的速度下根本放不出来。

所以就想将整个家庭局域网升级为千兆,幸好PC的网卡是千兆的。上网查了资料,家里预埋的网线是超5类的,勉强能支持千兆网络。但光猫作为路由器,网口是百兆的,还有IPTV口,和半双工口。而且华为光猫自动升级后,不能进入超级管理员设置了,而且光猫路由器的设置比较简单,又不能固定静态IP。想来想去,只能在在光猫下加装个有线路由器,实现局域网千兆、外网百兆。本来想买个软路由的,但本来安装的弱电箱太小了,塞了个光猫进去就没有太多位置了。所以就在网上找了小的省电的有线千兆路由,可以选的有ROS的和ER-X,看了看ER-X只有2个烟盒大小,小巧、省电,而且号称企业级路由,专业。但说界面是英文的,本来想对网络设置一定知识,按着教程设置应该没什么问题,就咬咬牙买了。

但买回来才意识到什么是企业级路由,对于只有家用路由器知识水平的我,才知道什么是恐怖,需要的理论知识根本就是几何级的提升,什么MTU,NAT,UPNP,UDP…以前都没听说过。经过了半个月的自学和调整,终于能算正常工作了。

上弱电箱的安装图,感觉再大点就真放不进去了:
new image - y1szk.jpg

正文:进入正题,自从装了ER-X后,都是看贴自学和不断调整,没有问过谁。对于没有专业知识的我,感觉好像就本来只有10的水平提升到60,有时候觉得自己这样折腾,值得吗?但人的水平还是有限的,到现在虽然整个网络能运行,但还是有两个问题无法解决。经过问题排除,我觉得问题应该出在光猫桥接和ER-X设置的问题上。希望各位网友和技术人员能帮我解答,谢谢大家了。

下面是我的网络拓扑图:
LAN.png

说下网络设置:
1.光猫设置成了桥接(192.168.0.1),由光猫LAN口接到ER-X eth0口,由ER-X拨号(看网友的帖子说ER-X作为2级路由影响速度,所以就照着设置了,现在可以上外网,证明ER-X拨号成功了。)
2.ER-X升级到了V1.9.1版本,Wizards->Basic Setup->eth0(PPPoE),启动默认防火墙,仅使用一个局域网,打开DHCP,IP地址192.168.1.1/255.255.255.0(eth1~4)作为LAN口。
3.按照教程开启了硬件加速OFFLOAD。
4.将两台PC设置静态IP(192.168.2/24)其中1个。
5.两台PC运行WIN10_PRO_X64,HTPC开启SMB共享。两台PC的网卡状态均显示为1G,之前PC的状态有时候会显示为100M所以我把所以网线全部改接了6类网线,除了入墙的超5类没法改。
6.家里的所以设备:PC、无线路由器、电视均上网正常。
7.MTU没改,界面显示PPPOE为1492,其他(LOCAL、INTERNET(PPPOE))均为1500,我不懂测MTU是多少,所以没改,但能上网。
8.2个兆交换机是腾达的50多块5口那种。

出现的2个问题:
1.外网的连接速度:两台电脑除了使用迅雷下载均能达成宽带最高速26Mps,但浏览网友,看网络视频的时候加载很慢,以前没用ER-X是很快没问题的,网速没上过10Mps,网页测速也是在10Mps左右,不稳定。不知道是不是MTU设置问题,还是防火墙问题、还是光猫接路由问题,还是电信限制,还是NAT问题?我真的不懂。试着改MTU,UPNP,关闭防火墙,均无改善。难道要我改回光猫拨号,ER-X作为2级路由,那我下面的无线路由器要变3级路由器了~

2.第2个问题简直让我崩溃,局域网传输速度很慢。而这个传输慢是单向的(上图标识)。我也是尝试逐步排除问题实在没办法解决才求助的。
(1)除了埋墙的超5类网线,其他外接的全部换成6类网线了。(网线问题排除)
(2)尝试帖子教的优化WIN10共享优化,关闭网卡大文件传输IP4的,关闭差分压缩,还是不起作用。(WIN10设置排除)
(3)将HTPC搬到房间,在同一eth1口的千兆交换机下,发送和接收都达到了300Mps左右,超过了100Mps,证明千兆网络起作用了。(电脑网卡问题排除)
(4)我还有1台千兆有线的笔记本,也进行相同操作,在同一eth1下有线传输可以达到千兆,换到eth3下交换机和eth1的PC传文件,eth1的PC的发送可以达到千兆,但eth3的笔记本发送只有1MB\S,和HTPC一样。在eth2、eth4下没有接千兆交换机网线直连,向eth1的PC发送文件,结果也是一样1MB\S的速度,很慢。我用的是飞鸽传书,iperf程序测速。
(5)经过以上测试,基本确定是在同一eth1下的传输速度都可以达到千兆,但在不同eth口下(eth2、eth3、eth4)向eth1传输文件,速度都很慢,应该只有10Mps的速度,连100Mps都没,这个真是很不应该,我也不知道怎么设置,是不是NAT设置,还是初始设置的时候要选择WAN+2LAN2,(我选的是Basic Setup,PPPOE拨号,开启DHCP,开启默认防火墙,使用一个LAN,应没有什么问题啊。)
(6)为什么不同eth口下单向传输可以达到千兆,证明网线、千兆交换机,路由器是没问题的,那为什么反向回传却慢得不得了?希望各位网友和技术人员能帮我解答,谢谢大家了。

楼主试着把er-x的基本防火墙去掉再试试看,基本可以判断是eth1—eth4之间通路比较慢,如果不行,试着硬起er-x,再重新设置下,offload是肯定要设置的,最好把配置文件发到论坛让版主看看。 我自己家的er-x开启offload是一点问题没有

局域网一个千兆交换机,一百多搞定。

不会是什么时候不小心把eth1接口速度设成了10m吧

eth1-4口 本身就应该是千兆交换 吧?

关于5,你可能需要查这件事:
ER-x的那个联发科的处理器带有交换机模块,因此应该确保你的eth1,2,3,4都在同一个sw?(?是数字,0比较多)组下,这样它们之间应该就有线速转发的性能。
这种情况下Pc<->HTPC只不过是经过三个千兆交换机,不应出现网速问题。

超5类是完美支持千兆网络的。事实上超五类线和更高等级的线对千兆以太网的支持都是一百米的级别

我感觉好像要设置成WAN+2LAN2,还有MTU你可以测试一下,先电脑直连光猫,拨号成功后进入CMD输入命令:netsh interface ipv4 show subinterface,就可以看到你的MTU值。然后输入命令:netsh interface ipv4 set subinterface “连接名” mtu=xxxx store=persistent,就可以修改电脑的MTU值,MTU=XXXX,那4个X要手工填写,范围在1400~1500之间,也就是你先前测的结果。

看样子是ubnt交换芯片的能力根本不足以达到1G的速度。

楼主可以去掉两个交换机,PC直连路由器试试文件传输速度,看看能不能达到1G?

建议9楼方案,如果达不到,加一个交换机接在ER-X的一个口上,其他的线全接交换机上。

ERX 送给我,我送你一个5口千兆交换机替换ERX,恢复光猫作为路由器。完美解决。

http://bbs.ubnt.com.cn/static/image/smiley/default/titter.gif:stuck_out_tongue_winking_eye:

检查一下是不是QOS的问题,把QOS关闭试试

我和LZ的问题一样,刚入手er-x的时候,局域网能达满速,nas和pc的传输最高能到125M,后来不挂PT了,也就没关注内网传输,但前几天刚又混了个PT号,就打开NAS继续用,下了蓝光看的时候发现一直缓冲,进NAS和PC看了下确定都是1G的速度,但是两者传输最快只有11M,偶尔能到50M,就马上又降下来了,这是NAS到PC的速度,PC到NAS更惨,每秒只有2M,恢复出厂、硬启都试过了,就是不行,确定网线什么都没问题,因为我换成K2P,能达到110M,换ER-X就不行了,但是以前也能满速啊,路由只是简单的设置了PPPOE拨号,广告过滤,SS什么全没装,就是达不到原来的网速了,不知道怎么回事。

1赞

请问楼主问题解决没有? 我也遇到这个问题,内网访问速度不超过10MB/s.只能达到百兆局域网的速率。不知道是哪儿的设置出现问题。