关于DHCP时间、硬件时间、系统时间的不匹配问题


DHCP的过期时间是UTC时间,系统是北京时间,如何让硬件时间与系统时间同步?谢谢

设置一下路由器的时区
点左下角的system,拉出的窗口设置


然后拖到最下面,保存配置

各种都试了还是不行,可能是硬件时间和系统时间不同步,系统时间对的是ntp同步的,但硬件时间是utc


而且我每次设置时区,好像有问题,在log里会出现上面这图里的提示,在1.X版本时候提示错误。在2.X版本中提示这两条,请大神帮忙解释一下,多谢


已设置,log里时间是对的,但DHCP中的租期是按照UTC时间显示的,比北京时间早了好久,我DHCP租期设置7200秒,这样动态获得的IP地址过期时间是在获得时间之前

求大神指点,谢谢

实在是没看出这有什么问题,linux的RTC默认都是UTC的,而且erx看起来好像没有硬件RTC

如果一定要改,可以试试这个,不过没有RTC,这个设置起来估计没用
image

另外,也许因为你用的默认dhcpd吧,我是用dnsmasq,log monitor里根本看不到租约相关log,眼不见为净。
set service dhcp-server use-dnsmasq enable

租约8天
/var/log/dnsmasq.log


网页

如果一定要用dhcpd,只能试试 参考
set service dhcp-server global-parameters “db-time-format local;”
这个配置参数了,因为我不是用dhcpd,所以不太确定这个是否有效,配错了会导致dhcpd无法启动哦,最好备份一下配置。

这个只是rsyslog重启的日志,看起来好像没啥问题

谢谢大哥了,我参考一下,谢谢